Sunday 12 August 2012

AIX Concepts

netcdctrl -t dns -e hosts -s /tmp/netcd.cache.out


What is SPOT?


a SPOT (shared product object tree),
and the pSeries to be migrated will have to be defined as objects
on the NIM server environment.

AIX Firmware


To determine the currently installed firmware level, read the documentation for the
appropriate hardware system. For example, use the following AIX command for checking the
firmware level of the IntelliStation POWER 275:

lscfg -vp | grep -p Platform
This command will produce a system configuration report similar to the following:
Platform Firmware:
ROM Level.(alterable).......3F030703
Version.....................RS6K
System Info Specific.(YL)...U1.18-P1-H2/Y2
Physical Location: U1.18-P1-H2/Y2
The ROM Level line lists the level of the currently installed firmware. In the example, the
current firmware level is 3F030703.


AIX Advanced Interactive Execute
APAR Authorized Program Analysis Report
BOS Base Operating System
CDE Common Desktop Environment
CD-ROM Compact Disc - Read Only Memory
CHRP Common Hardware Reference Platform
CPU Central Processing Unit
DNS Domain Name System
FTP File Transfer Program GB Giga Byte
HMC Hardware Management Console
ITSO International Technical Support  Organization
JFS Journaled File System
KSH Korn Shell Environment
LAN Local Area Network
LPP Licence Program Product
LUM Licence Use Managemant
LVM Logical Volume Manager
MCA Micro Channel Architecture
ML Maintenance Level
NFS Network File System
NIM Network Installation Management
NIS Network Information Service
NLS National Language Support
OS Operating System
PreP Power Reference Platform
RISC Reduced Instruction Set Computing
RTE Runtime Environment
SMIT System Management Interface Tool
SPOT Shared Product Object Tree
TCL/TK Tool Command Language /Toolkit
TZ Time Zone
VPM Virtual Product Modeling
WDFM Withdrawn from Marketing
WDFS Withdrawn from Service


Aix Booting

POST
/etc/rc.boot
/etc/inittab

/usr/lib/boot
/usr/lib/drivers

telinit [level number]
halt
init
poweroff
reboot
shutdown
uadmin

bosboot - [user new kernel]
bootinfo [display boot information]

shutdown -Fr [reboot the machine]

shutdown [power off the machine

halt [power off the machine]

/etc/security/.profile - profile template
/etc/profile
/etc/environment

/etc/security/.profile
smitty device
mkdev,rmdev,chdev,lsdev

smitty tcpip
mktcpip
ifconfig
chnamsv - [change the name service]
rmnamsv - [unconfigure the same service]
/etc/resolv.conf - [display the name service]
vi /etc/netsvc.conf [NSORDER environment variable]

change a hostname

#chdev -l inet0 -a hostname=hoostname
# /etc/services
# /etc/protocols
# iptrace
# netstat
# nfsstat - [ display the NFS and RPC statistics]
# netpmon - [ Display the Network statistics I/O and CPU usage]
# svmon [snapshot of virutual memory]
# vmstat [display virtual memory statistics]
# iostat or filemon [ display I/O statistics]

lsps -a
/etc/hosts.equiv  [specity remote users and host that can execute commands on the local host]
/var/adm/sulog
/etc/syslog.conf

backup operating system - mksysb or mkcd

start/stop sciprts ->/etc
device directory ->/dev

Display the RAM
#bootinfo -r or prtconf

Aix Package

Logical grouping of Packages - Bundle

installp -a or smitty install_latest
installp -r [remove package]
installp -u [committed package]

lslpp - L - [display installed packages]
installp -r or smitty reject  -  [remove a patch]
lppchk - [to verify correct installation]

AIX Storage Structure

lsfs - [it reads output of /etc/filesystems]

a disks is composed of physical partions
a physical volume is a physical disk
a volume group is composed of physical volumes
a volume group is devided into logical volumes
a file system is placed onto a logical volume.
a logical volume is extensible and can reside on more than one physical volume.

smitty lvm
migratepv [move logical volume to another physical volume]
mklv,extendlv,rmlv

mkvg,reducevg,extendvg



AiX Print

http://aix4admins.blogspot.com/

smitty print
mkdev
qadm
lpc
lpstat
lpadmin -p [change a print queue]
chque
chquedev
chviprt
lpadmin -x [remove print queue]
lsque
lsquedev
lsvirprt
lpstat [display the print queue]

GPFS

About GPFS

The General Parallel File System (GPFS)
it is a high performance shared disk clustered file system

GPFS proides concurrent high-speed file access to applications executing nodes of clusters.
it can be used with AIX 5L cluster, Linux clusters, on Micrsoft Windows Server, or a heterogeneous cluster of AIX, Liux and Windows nodes. In addition to providing file system storage capacbilities, GPFS provides tools for management and administration of the GPFS cluster and allows for shared access to fie systems from remote GPFS clusters.

Pre-Requisite for GPFS

AIX 5.3 SOE Patchset 13 or later, Aix 6.1 SOE Patchset 6 or Later
GPFS version 3.3 with ML4

Take a alt disk backup before seting up gpfs

Make sure the cluster disk is visible on both nodes.

SSh Configuration between GPFS nodes.

for cluster managment it is requirment of gpfs that ssh keys are configured for the root acccount for connections between cluster nodes. This only applies for coonnections from manager nodes to manager nodes and from  manager nodes to client nodes. Notes that manager node also needs the ability to connect to itself via ssh

# lslpp -l |grep -i gpfs
# mmcrcluster -N /tmp/gpfs.allnodes -p hostname -s hostname -r /usr/local/bin/ssh-R/usr/local/bin/scp -C xxxx
# mmgetstat -a [current status]
# mmlscluster [to list file for gpfs]
# vi /tmp/gpfs.disk [adding the gpfs file need to configure in hdisk]
hdisk6:hostname-backup1,hostname-backup2::dataAndMetadata:1;arp19gpfs1
# mmcrnsd -F /tmp/gpfs.disk -v no
# mmlsconfig
# mmcrfs gpfs-name-F /tmp/gpfs.disk -T /gpfs-name -B 64K -A yes
# mmlsfs gpfs-name
# mmshutdown -a [shutdown gpfs on all nodes]
# mmchconfig tiebreakerdisks="gpfs-name" [to verify the outputs @lspv cmds]
# mmstartup -a
# mmount -a  /gpfs-name
# mmshutdown [to single gpfs filesystem for shutdown]
# mmshutdown -N node,[node,node] [shutdown the filesystem on the listed nodes]

Backup-Files

The Default Location is /var/hacmp/clverify/clverify.log
lsmap -all |grep -p servername
mkdir -p /backup/reports/`hostname`
netstat -in >/backup/reports/`hostname`
netstat -i >/backup/reports/`hostname`/netstat-in.`hostname`
netstat -nr> /backu/reports/'hostname`/netstat -nr.`hostname`
ps -ef >
/usr/lpp/EMC/Symmetrix/bin/inq.aix64_51 -all>
df -g>
df |wc -l >
lspv >
lsvg -o>
prtconf >
lsvg -l lsvg >
lscfg -vp >
lsfs -a >
ifconfig -a >
lsdev -Cc disk >
lsdev >
powermt display dev=all >
vxdisk -o alldgs -e list>
vxprint -ht>
bootlist -m normal -o>
bootinfo -b >
hastatus -sum>
hastatus >

start the server in sms mode with HMC commands

chsysstate -r lpar -o on -m SK25_15_IFB_p570_SN034343 -n servername -b sms -f servername-normal
cfgmgr
varyon datavg
varyon appvg
mountall